Back to overview
Downtime

🛠️ Scheduled Maintenance

Apr 18 at 01:00pm CDT
Affected services
Main Site
Content Delivery Network (CDN)
Alf's Proxy
Blog site
Rex Discord Bot Dashboard

Resolved
Apr 18 at 01:23pm CDT

The scheduled maintenance on the server has been successfully completed as of 1:23 PM CDT. All systems are back online and operating normally. Thank you for your understanding during the downtime.

Created
Apr 18 at 01:00pm CDT

We will be performing scheduled maintenance on our server to ensure continued performance, security, and reliability. During this time, the server may be temporarily unavailable. We appreciate your patience and understanding.

Start Time: 1PM CDT
Estimated Duration: 1 Hour

Thank you for your support!